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Opis aplikacije - Model funkcioniranja pristupnih rampi na autoputu (Pay Toll)

Aplikacija simulira upravljanje naplatnim rampama na autoputevima. Model sadrži četiri rampe sa mogućim stanjima – otvorena “ON” i zatvorena “OFF”. Svaka rampa ima zaseban red čekanja. U slučaju da ispred rampe nema auta red čekanja te rampe je nula. Na rampama postoje magnetne kartice za naplatu. Prilikom prolaska vozila kroz rampu vrši se dekrementiranje broja kartica za tu rampu. Kartice se mogu u određenim slučajevima dopunjavati (50 komada po dopuni). 
Broj auta koja dolaze na rampu simulira se tako da se svakih 9,5 sekundi generiše slučajan broj između 0 i 15. Kako će biti raspoređena auta koja su došla zavisi od moda upravljanja i statusa na rampama.

Da bi jedno auto prošlo kroz rampu potrebno je 2,1 sekundu. 

Rampama je moguće upravljati na dva načina:

· automatski i 
· manuelno.
Automatski mod upravljanja

Kod automatskog moda upravljanja, otvaranje i zatvaranje rampi se odvija u zavisnosti od ukupnog broja vozila koja čekaju u redu za prolazak na autoput. U ovom modu upravljanja bar jedna rampa (prva) je uvijek otvorena. Ako ispred rampi čeka:

- manje od 20 vozila - otvorena je jedna rampa,
- od 20 do 40 vozila - otvorene su dvije rampe,
- od 40 do 60 vozila - otvorene su tri rampe, 
- preko 60 vozila - otvorene su sve četiri rampe. 
Broj otvorenih rampi kod automatskog upravljanja ne zavisi od stanja magnetnih kartica na rampama. Ukoliko broj magnetnih kartica na nekoj od rampi spadne na 10, automatski se vrši dopuna na 100 kartica i samim tim nema potrebe da se rampa zatvori. Kada se broj kartica smanji na 30, aktivira se alarm upozorenja, a kad je taj broj manji od 10 aktivira se alarm koji se sam isključi nakon dopune kartica.

Budući da svaka rampa ima individualan red čekanja, prilikom dolaska novih auta (svakih 9,6 sekundi) potrebno je napraviti pravilnu raspodjelu. 
Raspoređivanje se vrši tako da se broj auta koja dođu dijeli na broj otvorenih rampi. U slučaju da broj auta koja dođu nije djeljiv sa brojem otvorenih rampi, ostatak dijeljenja dodaje se na prvu rampu. Za ovakav način raspoređivanja opredjelili smo se zbog ograničenja razvojnog okruženja - u VB-u nije moguće unutar jedne funkcije dva puta dodijeliti vrijednost nekom tagu iz OPC simulatora.  
Ako je otvorena jedna rampa i broj auta koja čekaju na njoj zajedno sa brojem auta koja su došla ne prelazi 20, sva auta koja su došla biće dodana na red čekanja prve rampe. 
Ako broj auta koja čekaju na prvoj rampi zajedno sa brojem auta koja su došla prelazi 20, otvorit će se i druga rampa. Auta koja su došla biće ravnomjerno raspoređena na obje rampe. 
Npr. došlo je 8 auta. Na obje rampe će biti dodana po 4 auta. U slučaju da je došao neparan broj auta, npr. 9, onda će na prvu rampu biti dodano 5, a na drugu 4 auta. 

Pretpostavimo da ukupno čeka 80 auta. Ovo znači da su otvorene sve četiri rampe. Takođe pretpostavimo da je došlo 15 auta. U ovom slučaju na rampu 1 će biti dodato 6 auta, a na ostale rampe po 3 auta. 

Manuelni mod upravljanja
Manuelni mod upravljanja dozvoljava korisniku potpuno upravljanje rampama. Potpuno upravljanje podrazumjeva otvaranje i zatvaranje rampi po želji, dopuna kartica i prebacivanje auta sa jednog reda čekanja u ostale. Manuelno punjenje kartica nije dostupno u automatskom modu upravljanja. Rampe se ni u kom slučaju neće same upaliti, čak i ako su sve četiri rampe zatvorene. 

Raspoređivanje auta koja su došla radi se po sličnom principu kao i u automatskom modu. Auta koja pristignu ravnomjerno se raspoređuju na sve otvorene rampe. Razlika u odnosu na automatski mod je što rampe ne moraju biti redom otvarane (rampa 1, rampa 2, rampa 3...), već mogu biti otvarane prema želji korisnika (npr. rampa 2 i rampa 4, ili samo rampa 3...). 

U ovom modu sve četiri rampe mogu biti zatvorene. Tada se oglašava alarm, koji se isključuje nakon paljenja neke od rampi. Kada su sve rampe zatvorene, pristigla auta raspoređuju se ravnomjerno na sve rampe.
U manuelnom modu upravljanja korisnik treba voditi računa o broju magnetnih kartica na pojedinim rampama. Kada nestane kartica na rampi, ona se automatski zatvara. Da bi se ponovo otvorila korisnik mora prvo dopuniti kartice. Dugme za dopunu kartica, dopunjava 50 kartica svakim klikom na njega.
U slučaju da ispred rampe postoji red čekanja, a broj kartica na rampi iznosi 0, tj. rampa je zatvorena, korisnik dobiva mogućnost da prebaci auta iz tog reda u druge redove čekanja. Auta koja se prebacuju bivaju ravnomjerno raspoređena na druge otvorene rampe.
I u ovom modu aktivirat će se alarm upozorenja kada broj kartica spadne na 30, i drugi  alarm koji će se aktivirati ako broj kartica na rampi spadne na 10. Treći alarm, karakterističan samo za ovaj mod, aktivirat će se ako broj kartica spadne na nulu. 

Pored upravljanja i kontrole postoje i ekrani za praćenje alarma i trendova, što je detaljno objašnjeno u poglavlju Uputstvo za korištenje aplikacije.
Postavke aplikacije

Kreiranje putanje direktorija 

Potrebno je kreirati sljedeću putanju direktorija: 
C:\SPSS\ICONICS06\GRUPA15
U  direktorij GRUPA15 raspakovati aplikaciju Grupa15.zip

OPC Simulator

Potrebno je pokrenuti aplikacijski OPC simulator:

1. Pokrenuti OPC Simulator izborom Start → All Programs → ICONICS GENESIS32 → OPC Simulator 

2. Na Toolbar-u izabrati File → Open, te učitati datoteku:
 
C:\SPSS\ICONICS06\GRUPA15\OPC simulator.sim 

Hijerarhijska struktura otvorene datoteke bi trebala biti kao na sljedećim slikama:
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Language Configurator
1. Iz menija Start → All Programs → ICONICS GENESIS-32 → Languages pokrenuti Language Configurator  

2. Iz File menija izabrati opciju Open i učitati datoteku C:\SPSS\ICONICS06\GRUPA15\Languages\LanguageConfig.mdb 
3. Importovati xml file odabirom File → Open → XML Import  i učitati fajl C:\SPSS\ICONICS06\GRUPA15\Languages\LangSupSample.xml
4. U meniju File izabrati opciju Make Active kako bi učitana datoteka postala aktivna 

Hijerarhijska struktura otvorene datoteke bi trebala biti kao na sljedećoj slici :
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ODBC izvori podataka
S obzirom da postojeće podatke imamo sačuvane u bazi, potrebno je importovati bazu na sljedeći način:
1. Otvoriti Control panel i izabrati Administrative Tools → Data Sources (ODBC) 

2. Sa otvorenog prozora ODBC Data Source Administrator izabrati tab System DNS 
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3. Na izabranom tabu kreirati dva ODBC izvora podataka:

· jedan za alarme – imenovati ga SPSSIC06PayTollAlarm i izabrati bazu za alarme sa putanje: 

C:\SPSS\ICONICS06\GRUPA15\Alarm\AlarmHistoryData.mdb 
· drugi za trendove - SPSSOC06PayTollTrend i selektovati bazu za trendove sa putanje:   C:\SPSS\ICONICS06\GRUPA15\Trend\TrendHistory.mdb 
kao što se može vidjeti sa slike:
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Alarm Server Configurator


Kao i za Language Configurator, potrebno je podesiti aplikacijsku konfiguraciju za Alarm Server Configurator, na sljedeći način:
1. Pokrenuti Alarm Server Configurator odabirom opcija Start → All Programs → ICONICS GENESIS-32 → AlarmWorX32 → Alarm Server Configurator 

2. Sa File menija izabrati opciju Open, te učitati datoteku    C:\SPSS\ICONICS06\GRUPA15\Alarm\AlarmServer.mdb 

3. Sa menija File izabrati opciju Make Active kako bi učitana datoteka postala aktivna 

Hijerarhijska struktura otvorene datoteke bi trebala biti kao na sljedećoj slici:
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Alarm Logger Configurator

1. Pokrenuti Alarm Logger Configurator odabirom opcija Start → All Programs → ICONICS GENESIS-32 → AlarmWorX32 → Alarm Logger Configurator 

2. Sa File menija izabrati opciju Open, te učitati datoteku    C:\SPSS\ICONICS06\GRUPA15\Alarm\AlarmLogger.mdb 

3. Hijerarhijska struktura otvorene datoteke bi trebala biti kao na sljedećoj slici: 
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4. U lijevoj strani browser-a  izabrati  Nodes. Pritiskom na dugme Browse odabrati ime računara na kojem se aplikacija pokreće.
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5. Sa menija File izabrati opciju Make Active kako bi učitana datoteka postala aktivna
6. Pritisnuti na semafor (sa crvenim svjetlom) da bi se aktivirao Alarm Logger (semafor postane zelen).
Trend WorX32 Configurator

1. Odabirom opcija Start → All Programs → ICONICS GENESIS-32 → TrendWorX32 pokrenuti TrendWorX32 Configurator 

2. U File meniju izabrati opciju Open, te učitati datoteku    C:\SPSS\ICONICS06\GRUPA15\Trend\TrendLogger.mdb 

3. Promijeniti ime mrežnog čvora na ime lokalnog računara (zaokruženo crvenom bojom)

4. Sa menija File izabrati opciju Make Active kako bi učitana datoteka postala aktivna 

Hijerarhijska struktura otvorene datoteke bi trebala izgledati kao na sljedećoj slici:
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Persistent Trending Configurator

1. Odabirom opcija Start → All Programs → ICONICS GENESIS-32 → TrendWorX32 pokrenuti Persistent Trending Configurator 

2. U File meniju izabrati opciju Open, te učitati datoteku    C:\SPSS\ICONICS06\GRUPA15\Trend\PayTollPersistentTending.b32 

3. Prije pokretanja aplikacije obavezno pokrenuti Persistent Trending OLE automation server pritiskom na ikonu semafora kao na sljedećoj slici:
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TrendWorX32 Reporting
1. Pokrenuti TrendWorX32 Reporting (Start → All Programs → ICONICS GENESIS-32 → TrendWorX32 → TrendWorX32 Reporting)

2. Na Toolbar-u izabrati File → Open, te učitati datoteku C:\SPSS\ICONICS05\GRUPA15\Trend\ TWXReport1.rtw
3. Hijerarhijska struktura otvorene datoteke bi trebala biti kao na sljedećoj slici:
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4. Pritisnuti na semafor (sa crvenim svjetlom) da bi se aktivirao TrendWorX32 Reporting (semafor postane zelen).

DataWorX32
1. Pokrenuti DataWorX32 (Start → All Programs → ICONICS GENESIS-32 → Tools → DataWorX32)

2. Na Toolbar-u izabrati File → Open, te učitati datoteku C:\SPSS\ICONICS05\GRUPA15\Data Worx\DwxConfigurator.mdb
3. Hijerarhijska struktura otvorene datoteke bi trebala biti kao na sljedećoj slici:
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4. Pritisnuti na semafor (sa crvenim svjetlom) da bi se aktivirao DataWorX32 
    (semafor postane zelen).
GenTray

1. Potrebno je pokrenuti GenTray iz menija Start→ All Programs → ICONICS GENESIS-32  → Tools 

2. Startati AlarmWorX32 Server i AlarmWorX32 Logger, TrendWorX32 SQL Server i TrendWorX32 Reporter 
Uputstvo za korištenje aplikacije

Početni ekran

Da bismo pokrenuli aplikaciju potrebno je pokrenuti GraphWorX32 
(Start → All Programs → ICONICS GENESIS-32 → GraphWorX32 → GraphWorX32). Nakon toga potrebno je otvoriti početni ekran aplikacije 
(File → Open → C:\SPSS\ICONICS05\GRUPA15\Main.gdf). 
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Sa ovog ekrana moguće je doći do:

· ekrana za upravljanje i nadzor rampi (Upravljanje i nadzor), 

· ekrana za pregled trendova (Trendovi),

· ekrana za pregled alarma (Alarmi realnog vremena i Historija alarma),  
· ekrana za hijerarhijski pregled.

Na ovom ekranu je također moguće:

· odabrati željeni jezik (bosanski ili engleski), 

· vidjeti dan, datum i vrijeme, 

· prijaviti se ili odjaviti kao korisnik,

· vidjeti listu logovanih korisnika,

· pristupiti kratkom ili detaljnom help fajlu.
Povratak na početni ekran omogućen je sa svih ekrana klikom na ikonicu koja predstavlja ekran Početna forma  a izgleda ovako:
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Slika manuelnog moda

Upravljanje i nadzor predstavlja glavni najvažniji ekran aplikacije. Na ovom ekranu je prikazana sama simulacija rampi, gdje takođe imamo mogućnost da upravljamo istim. Slika iznad predstavlja manuelni mod u kojem se vide sve komande. Automatski mod ne dopušta korisniku upravljanje, te samim tim sakriva neke komande. 
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Slika automatskog moda

Na ekranu ima dosta podataka i kontrola, koje su označeni brojevima na slici manuelnog moda. Objašnjenja slijede:
1. Povratak na glavni meni

2. Pregled alarma, odnosno prebacivanje na ekran alarma

3. Pregled trendova, odnosno prebacivanje na ekran trendova

4. Pomoć. Aktiviranje help file-a koji je napisan u posebnom programu (.chm)

5. Zatvaranje aplikacije

6. Dugme za otvaranje/zatvaranje rampe. Ovo dugme ima punu funkcionalnost u manuelnom modu, dok u automatskom modu nema - logika programa upravlja uključivanjem i isključivanjem rampi.
7. Indikator statusa rampe je obojen zeleno kada je rampa otvorena, a crveno kada je rampa zatvorena

8. Dugme za dopunu kartica. Ovo dugme je dostupno korisniku samo u manuelnom modu upravljanja i ima funkciju dopune 50 kartica. Ako na rampi nema niti jedne kartice, dugme će da blinka mijenjajući podlogu iz sive u crvenu svake sekunde.

9. Red auta ispred svake rampe je dinamički. Red je prikazan kao gif animacija koja se povećava odnosno smanjuje u zavisnosti od broja auta koja čekaju ispred pojedine rampe. Dužina reda za 30 i više auta je konstantna, znači red se neće dalje povećavati.
10. Dugme za prebacivanje auta u druge redove čekanja se pojavljuje u situaciji kada ispred određene rampe postoji red čekanja, a na rampi nema kartica (znači rampa je ujedno i zatvorena). Pritiskom na ovo dugme, auta koja su čekala u redu ispred rampe prebacujemo na druge rampe. Naravno dopunom kartica i ponovnim otvaranjem rampe takođe bismo rješili problem.

11. Digitalni indikator broja auta koja čekaju ispred rampe. Maksimalni broj koji može prikazati je 999, što je svakako nemoguća situacija.
12. Tablica podataka o trenutnom stanju naplatnog prilaza prikazuje detaljne informacije o statusu rampe, broju auta koja čekaju u svakom pojedinom redu, broju kartica na rampi i o broju auta koja su prošla svaku pojedinu rampu.

13. Prikaz broja auta koja pristižu, odnosno broj auta koja treba rasporediti. Algoritam raspoređivanja možete pogledati u poglavlju Opis aplikacije, podnaslovi Automatski mod upravljanja i Manuelni mod upravljanja.

14. Omogućava prebacivanje iz automatskog moda upravljanja u manuelni i obratno. Tačkica moda upravljanja u kojem aplikacija radi ispunjena je crnom bojom.
15. Tipka Reset ima funkciju postavljanja početnih postavki - postavlja sve redove čekanja na 0, broj auta koja su prošla takođe na 0, prebacuje aplikaciju u automatski mod upravljanja (samim tim otvara prvu rampu a ostale zatvara), postavlja po 100 kartica na sve rampe i generiše 4 auta koja dolaze.
Do ovog ekrana, osim sa početne stranice može se doći i sa određenih drugih ekrana klikom na ikonicu koja predstavlja ekran Upravljanje i nadzor a izgleda ovako:
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Trendovi


Na ovom ekranu istovremeno mogu se pratiti historijski i real-time trendovi za:

· Opterećenost rampi, sa kojeg se prati red auta ispred svake rampe 
· Frekvenciju dolazaka, odnosno broj auta koja su pristigla 
· Prosječnu opterećenost rampi, sa kojeg se prati prosječno opterećenje svake rampe u odnosu na broj auta koja su pristigla, i kako su raspoređena (na redove koje rampe).

Svaki od navedenih trendova (i historijski i real-time) može se pojedinačno sam posmatrati klikom na površinu trenda kojeg želimo posebno posmatrati, kao što je naznačeno sa 1 na sljedećoj slici:
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Ostale kontrole označene brojevima na slici znače:

2. Povratak na glavni meni

3. Otvaranje izvještaja u vidu excel dokumenta, gdje su vremenski prikazane vrijednosti svih varijabli koje trendiramo 

4. Prebacivanje na ekran upravljanja i nadzora nad rampama 

5. Pregled alarma, odnosno prebacivanje na ekran real-time alarma

6. Pomoć. Aktiviranje help file-a koji je napisan u posebnom programu (.chm)

Do ovog ekrana, osim sa početne stranice može se doći i sa određenih drugih ekrana klikom na ikonicu koja predstavlja ekran Trendovi a izgleda ovako:
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Real - time trendovi


Kao što je već navedeno, real-time trendova koji se prate ima ukupno tri. Za svaki trend pojedinačno postoji ekran, a do njega se može doći kao što je navedeno u poglavlju Trendovi (tačka 1 sa gornje slike). Ekran za praćenje real-time trendova izgleda kao na slici:
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Pored ikonice za povratak na početnu formu i help file, sa ovog ekrana moguće je vratiti se na prethodni ekran Trendovi, kao i pogledati historijski pregled istog trenda. 
Historija trendova 

Ekran za historijske trendove vrlo je sličan onom za real-time praćenje trendova. 
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Jedina razlika na ovom prozoru, pored tipa trendiranja (history), je što se sa njega može otvoriti ekran za isti trend ali u real-time-u 


Real - time alarmi

Alarmi su podijeljeni po prioritetu i rampama da bi se olakšalo praćenje. 
U grupu kritičnih alarma čine slučajevi kada su zatvorene sve rampe i kada je nestalo kartica na jednoj od rampi jer je ona tada van funkcije. Alarmi upozorenja su obavijesti da je ostalo još manje od 30 i 10 kartica, na nekoj od rampi i velik red čekanja ispred jedne od rampi (preko 30 i 60 vozila).
Alarmi u modelu upozoravaju:
· kada je velik red čekanja na rampi (broj auta ispred rampe > 30) – Hi, 
· kada je prevelik red čekanja na rampi (broj auta ispred rampe > 60) – HiHi, 

· kada je ostalo 30 kartica na rampi – Lo,
· kada je ostalo 10 kartica na rampi – Lo,

· kada nestane kartica na rampi – LoLo,
· kada su zatvorene sve rampe  – HiHi
Svaki alarm je potrebno potvrditi dvostrukim klikom lijevog tastera miša na alarm koji se aktivirao. 
Pritiskom desnog tastera miša na dio ekrana gdje se prikazuju alarmi dobivamo meni na kojem možemo izabrati opcije: 
· ACK – dodatne opcije za potvrđivanje alarma
· Sort – sortiranje alarma po vrijednostima kolona
· Filter - prikazivanje podataka o alarmima koje sam korisnik odabere nakon kreiranja filtera

Izgled prozora alarma realnog vremena se vidi sa slike:
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Kao što se vidi sa slike, i na ovom ekranu možemo pratiti statuse rampi, redove, kao i stanje kartica. Pored toga moguće je i sa ovog ekrana izvršiti dopunu kartica, te izabrati ekrane za historiju alarma i upravljanje i nadzor.
Historija alarma
Ovaj ekran omogućava pregled alarma koji su se javili u određenom vremenskom periodu. 
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Nakon što je alarm potvrđen u ekranu za alarme u realnom vremenu, pojavit će se i u ekranu za historijske alarme.
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